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Bookmarks 
 

 
Bookmarks are a simple and easy way to transfer MoversSuite data to a Microsoft Word document.  
Using an integration API that is built into MoversSuite, data is transferred to predefined text fields 
(bookmarks) within a Microsoft Word file.  Once the program is launched from the main menu bar 
within the MoversSuite application, a separate Microsoft Word window will open with all the defined 
bookmark references replaced with actual data.  From this window, the file can be treated as any other 
Microsoft Word document where it can be edited, saved to disc, printed, emailed, etc. 
 
Using bookmark files, one can provide customized letters ready to be sent out, or create pre-filled 
forms, professionally displaying the details of an order request.  These and other documents can be 
created with little effort after learning the basics of bookmarking fields and files.  
 
Illustrated below is just one of the unlimited ways that bookmark files can be used.  The bracketed items 
are the bookmarked data fields that are replaced with actual MoversSuite data when the application 
renders the Microsoft Word file. 
 

 
Figure 1: Bookmark rendering process 

 
The benefit of automatically creating custom reports, forms, and letters on the fly is easily identifiable, 
and MoversSuite will continue to add to the list of available bookmark fields.  
 
In the following sections, one can learn how to define and render files containing bookmarks, add 
bookmark fields from the available list, and render theses file through the MoversSuite application. 
 

user_guide_to_bookmarks.pdf
available_bookmarks.doc
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Important: Microsoft Word 2003 or Microsoft Word 2007 must be set up on your application server 
and be accessible by MoversSuite.  Refer to the Welcome to MoversSuite Software topic for further 
requirements. 

 
Familiarity with Microsoft Word 2003 and/or Microsoft Word 2007 and the MoversSuite application and 
related administration tools is beneficial to get the most of this guide.   
 
This document references Microsoft Word 2007 for its examples, however, a user can also manage 
bookmark documents within Microsoft Word 2003.  For more information on either of these versions, 
refer to Microsoft Office Online and to the Word Help available within each product. 
 
The Microsoft Word 2007 application will accept documents created of either type. 
 
Note: The list of available bookmark fields can be found at support.moverssuite.com as well as within 

the Microsoft Word icon (  ) above. 
 
 
 
 
  

http://office.microsoft.com/en-us/default.aspx
http://support.moverssuite.com/
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Accessing Bookmark Files 
 
The term “Reports” is used generically to describe all forms, letters, reports, and other files that can be 
defined within MoversSuite.  All sections refer to the Reports and Report Profile setup areas within the 
MoversSuite Administration - web and Mover’s Suite Administration. 
 
The information presented in this section will educate a user on where to place bookmark documents 
and how to make administrative changes to allow MoversSuite and its user access to bookmark 
documents. 
 

Location of Bookmark Files 
 
Bookmark files are physical files that exist on the same application server as MoversSuite application.  
An administrator can place these files anywhere on the server that the MoversSuite application can 
access.  It is suggested that they reside within a folder entitled “mssShare” within the server’s directory 
structure.   
 
Although this directory is updated during the installation process of MoversSuite software, any custom 
files will not be overwritten.  Further, files setup in the subfolder of “mssLetters\Custom” will not be 
deleted or altered in any way by the installation process. 
 
Listed below is the standard, accepted location of files created outside of MoversSuite.  The files located 
within the Custom folder will not be overwritten when updates occur. 
 

 
Figure 2: Custom folder on the user's application server 

 
 
One way to identify which folder is being referenced by the application for bookmark files is to lookup 
the Reports setup information within the administration setup. 
 

Location of Bookmark Files 

1. Access  Mover’s Suite Administration, 

2. Select the Common > Reports > Reports > Reports setup, 
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Figure 3: Reports setup section within the Mover’s Suite Administration with Report Type filtering in 
effect 

 

3. Locate those records with a Report Type of “Letters”.  A user can click and drag the Report Type 
column heading into the “Drag a column header here to group by that column” row above to 
group by this type. 

 

Sample Reports setup of bookmark documents is displayed below: 

 

 
Figure 4: Reports setup example within the Mover’s Suite Administration 

 
 
The general properties of a bookmark file are listed in the table below.  Read more about these settings 
within the Reports topic. 
 
 

Reports Table Properties as they apply to Bookmark Files 
 

Field Name Description 

Menu Name The name of the file that appears in the MoversSuite application. 

Report Name The name of the physical file as it exists on one’s system.  For bookmark files, they will 
need to have the filename extension of .doc (Microsoft Word 2003) or .docx (Micrsoft 
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Word 2007). 

Report Path This is the path (directory) that is a prefix of the Report Name.  A path similar to 
\\Server\mssShare\Reporting\Instance\mssLetters\Custom\ may be in use, where 
the Server and Instance (both in red) would be unique to one’s system and may 
represent a specific setup or version of MoversSuite applicatione, respectively. 

Report Type Must be set to “Letters” to have bookmark files rendered as Microsoft Word 
documents.  It also instructs the program to make the file available through the 
application’s main toolbar option of Reports > Letters. 

System ID This field may contain a four-character identifier that is used to link the document to 
one of the several report buttons found within MoversSuite. 

For example, assigning a System ID of “CLAM” to will allow for the document to be 
made available through the Report/Letters button within the Claims interface. 

 

Render Type This field should be left blank for bookmark files. 

 
 

Tip: Another way in which to find the source location of a file is to launch an existing bookmark file 
from within MoversSuite, and then execute a Save As option when the Microsoft Word window 
appears.  Microsoft Word will attempt to save the file to the same location that is the source of the 
original document; which is also what is defined in the Reports setup for the document. 
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User Access to Bookmark Files 
 
Access to forms, letters, and reports is controlled through a Report Profile.  Reports can be linked to a 
profile which can be assigned to a user.  If either the user’s Report Profile does not access a particular 
report, or if the Report Profile is not linked to the report, then the user will not be able to launch or view 
it from within the application. 
 
So, in addition to knowing which reports are set up on one’s system, a user needs to identify which 
reports can be run from MoversSuite. 
 

Identifying User Access to Reports 

Use the MoversSuite Administration - web to view the Report Profile in use for a user: 

1. In MoversSuite Administration - web, 

2. Open User Setup > Personnel, 

3. Locate and select the Employee, 

4. Select the User Setup tab, 

5. View the Report Profile of the user, 

 

Figure 5: User Setup section of the Personnel setup from within the MoversSuite Administration - web 

 
Reference the Report Profile Detail setup within the administrative setup to determine which 
documents can be accessed: 

6. In Mover’s Suite Administration, 

7. Open the Common > Reports > ReportProfileDetail > Report Profile Detail setup, 

8. Locate those records that match the user’s Report Profile.   A user can click and drag the Report 
Profile column heading into the “Drag a column header here to group by that column” row 
above to group by this type. 

 
Following the above procedure will allow an administrator a see which reports are available for users 
through the Report Profile setting. 
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Figure 6: Report Profile Detail table setup within Mover’s Suite Administration 

 
The reports available to the sample profile illustrated above will appear as follows: 
 

 
Figure 7: Sample access to Letters within MoversSuite 

 
 
Learn more about adding documents and updating user’s Report Profile to access bookmark documents 
within the Bookmark File and User Access Setup section. 
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Bookmark File and User Access Setup 
 
The following procedure will allow an administrator to add bookmark documents to the list of available 
Reports and to allow users to access them through their Report Profile settings. 
 

Updating MoversSuite to recognize bookmark documents   

1. Open the Mover’s Suite Administration, 

2. Access the Common > Reports > Reports > Reports setup, 

3. Enter Menu Name, Report Name, Report Path, Report Type, and System ID using the Reports 
Table Properties as they apply to Bookmark Files table as a guide, 

4. Tab through the Render Type field to save the record, 

5. Repeat Steps 3 and 4 to add other bookmark documents to the list of Reports, 

Modifying a user’s profile to recognize bookmark documents: 

6. Access the Common > Reports > ReportProfileDetail > Report Profile Detail setup,  

7. Select a Report Profile (users that can access the report) from the available list.  Define new 
profiles within the Report Profile setup through Common > Reports > ReportProfile, if needed.  
Refer to the MoversSuite Administration topic for more information on defining new Report 
Profiles, 

8. Select the newly defined report title from the list of Report Names, 

9. Repeat Steps 7 and 8 assign other bookmark documents to other user’s Report Profiles. 

 
Upon successfully adding a document to the list of Reports and assigning the document to a user’s 
Report Profile, the user will be able to access them through the Reports > Letters menu options 
available within MoversSuite. 
 
If personnel records need to be updated to reference a specific Report Profile, then an administrator can 
follow the procedure listed below. 
 

 Updating the Report Profile for personnel 

1. In MoversSuite Administration - web, 

2. Access the User Setup > Personnel > Personnel setup, 

3. Locate Employees from the drop-down list, 

4. Select the User Setup tab, 

5. Press the Edit button to enable data fields to be modified, 

6. Select the Report Profile from the provided list, 

7. Press Save to keep the changes to this record, 

8. Repeat Steps 3 through 7 to update the Report Profile for other employees. 
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Once defined and accessible a user can generate bookmark documents from within MoversSuite.  Read 
more about this in the Viewing Bookmark Documents section. 
 
More information on adding and updating the documents is available within the online help under the 
Reports topic.  
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Working with Bookmark Documents 
 
There are a number of files included with each release of MoversSuite software that contain bookmark 
fields.  One of these is a move Confirmation Letter, and it is available within the listing of standard, 
provided reports.  This file will be used as an example within this section. 
 
 The information presented in the Accessing Bookmark Files section provides enough information to 
allow an administrator to locate the Confirmation.doc file, reference it correctly in the Reports setup, 
and modify user access to render the file within the application.  
 
Use a sample document to work through the following sections. 
 

Viewing Bookmark Documents 
 
Bookmark files are referenced through the MoversSuite application in two different ways: Through the 
main application’s toolbar by Reports > Letters and through buttons available within the application.  In 
either case, the program will render the data for the record that is selected, or active, within the 
application and send it to a Microsoft Word document. 
 

Viewing Bookmark Document within MoversSuite 

1. Access the MoversSuite application, 

2. Use the Find feature to select a record in any module and make it active within the application, 

3. Select Reports > Letters from the main toolbar, 

 

Figure 8: Accessing bookmark documents through the Reports > Letters menu 

4. Choose a report title from the list.  For example, select “Confirmation Letter” (or other 
document), to continue using the previous example.  Once a selection is made, a window should 
open containing a Microsoft Word document with data from the active record filled-in, 

 

Assuming that the Confirmation Letter was chosen, then the user will see Microsoft Word document 
similar to that displayed below.  The date, address, and other data were automatically inserted into 
the document. 
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Figure 9: Sample confirmation letter. 

 

Note: The version of the Microsoft Word that is used to render bookmark documents from within the 
MoversSuite application server may render documents slightly differently from the one that is typically 
used from a personal computer. 

 

Bookmark Fields Defined 
 
A bookmark is simply a point of reference within a Microsoft Word document that can be used for a 
number of purposes, including being a target for a hyperlink or table of contents.  It can also be used as 
a marker that a separate application, such as MoversSuite, can use to insert database values.  This latter 
use is the focus of this document.   
 
MoversSuite will recognize a number of bookmark fields within a Microsoft Word document and will 
replace them with data from the order being referenced at the time that the file is generated. 
 
All available bookmarks are contained within in the Available Bookmarks document (available at 
support.moverssuite.com or near the top of the Bookmarks topic) and each can be placed within a 
user’s own Microsoft Word documents by following the procedure within the Managing Bookmark 
Fields section. 
 
To effectively use the bookmarks a user should understand the attributes of bookmark fields. 
  

MoversSuite’s Bookmark Field Attributes 

 They are a cross-reference between database field values and Microsoft Word documents 

 They must be unique within each document 

 They are not case-sensitive 

 Must be an exact match to what the MoversSuite application expects 

http://support.moverssuite.com/
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 They can only be used once within each document 

 
The last attribute is a considerable limitation therefore the application has been modified to have 
multiple bookmark fields for several key fields.   The order record number, for example, may be needed 
more than once in any particular document, so bookmarks of “ordnum” and “ordern” have been created 
to pull the record’s Order Number; this allows a user to pull the value up to two times per document. 
 

Duplicate bookmark fields 
 
The table below lists all MoversSuite data values that can be referenced by more than one bookmark 
field; allowing a user to display the data multiple times within a single document. 
 

MoversSuite Data Available Bookmark Fields  

Order Number ordnum 

ordern 

Shipper Name Complete shipper name: 

shipper 

fname  

FirstName2 

Additionally, the shipper’s first and last name can be referenced 
through the following: 

FirstName 

LastName 

Shipper’s Origin Address  Complete address for origin address: 

oaddress 

Additionally, the following values can be used to make up the origin 
address: 

MovingFromAddr1 (and MovingFrom) 

MovingFromAddr2 

MovingFromAddr3 

city (and city2 and ocity) 

zip 

OriginCountry 

Shipper’s Destination Address  Complete address for destination address: 

daddress 

Additionally, the following values can be used to make up the 
destination address: 
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MovingToAddr1 (or MovingTo) 

MovingToAddr2 

MovingToAddr3 

Dcity (or DestCity) 

Dzip 

DestinationCountry 

Booking Agency Salesperson Sales 

SalesPerson 

Booking Agency Coordinator coord 

coord2 

coord3 

Booking Coordinator’s Email email1 

email2 

Origin Agency’s Phone Number oanumber 

oaphone 

Claim Adjuster ClaimAdjuster1 

ClaimAdjuster2 

ClaimAdjuster3 

 
Microsoft Word also requires that bookmark fields be a single word in length.  Multiple word titles, such 
as “Shipper Name”, are not allowed.  The program also ignores case, so “Shipper” is treated the same as 
“shipper” (not capitalized). 
 
There are also bookmarks defined by MoversSuite that will list more than a single data values.   The 
following bookmark fields can be referenced to retrieve the listed data. 
 

Bookmarks that retrieve multiple data values 
 

Bookmark Field Description 

ClaimItems This bookmark will retrieve all Claim Items records for a particular Claim 
record. 

The following data will display for each record associated to a Claim 
when this bookmark field is in use: 

 Description 

 Claim Damage Type 

 Claim Amount 

 Settlement Amount 
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QuoteTable When this bookmark is selected, all Quotes and all Quote Detail records 
associated to an Order will be listed.   

The following data will appear for each Quote record (by detail or 
grouped record): 

 Quote Description 

 Charge 

 Rate 

 Quantity 

 Vendor Quoted Charge 

 Vendor Actual Charge 

 Rate Type 

 Item Code 

 Service Provider Type 

Stores Data related to all jobs associated to a Special Services order within the 
Store Information tab will display when this bookmark field is 
referenced. 

The following data will display for each record associated to an Order 
when this bookmark field is in use: 

 Install Date  

 Install Time 

 Store Name 

 Store Number 

 Store Address 

 Story City, State and Zip 

 Store Contact 

 Store Phone 

VesselAndFlightInfo The following data will display for each record associated to an 
International Order when this bookmark field is in use: 

 Vessel/Flight 

 Estimated Departure Date 

 Actual Departure Date 

 Estimated Arrival Date 

 Actual Arrival Date 

 Destination Port 
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Viewing Bookmark Fields 
 
Bookmark fields are text fields that Microsoft Word uses as a reference point within a document to 
insert database values for an Order into.  They are hidden from general viewing and a Microsoft Word 
option must be turned on in order for a user to recognize them within their documents. 
 
Use the following procedure to identify which bookmarks are currently established within a document. 
 

Enabling the Show Bookmark Option 

1. Open Microsoft Word program, 

2. Open a document containing bookmark fields (e.g. “Confirmation.doc”), 

3. Turn on the Show Bookmarks option as follows:  

In Microsoft Word 2003:   

a. Select Options from the applications toolbar by Tools > Options, 

b. Click on the View tab, 

c. Check the box entitled Bookmarks within the Show section, 

d. Close the dialog. 

In Microsoft Word 2007:  

a. Click on the Microsoft Office Button  

 

b. Click on the Word Options, 

c. Select Advanced from the list, 

d. Place a check next to Show bookmarks in the Show document content section, 

 

Figure 10:  Word Options dialog 
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e. Press Ok to keep the change and to close the Word Options dialog. 

 

Upon completion, all bookmark fields within the document will appear encapsulated in braces. 
 

Bookmark field with Show Bookmark option turned off: 
 

 
Bookmark field with Show Bookmark option turned on: 
 

  
 
The following example (Figure 11), illustrates the visible bookmarks as seen within the Confirmation.doc 
file. 
 

 

 
Figure 11:  Confirmation letter document sample 
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Bookmark Dialog 
 
A user can access the Bookmark dialog within Microsoft Word to see all bookmarks in use for the 
particular document. 
 

View Available Bookmarks within a File 

1. Open a Microsoft Word document that contains bookmarks, 

2. Access the Insert options, 

3. Click on the Bookmarks button within the Links section and the Bookmarks dialog box should 
appear, 

 

Figure 12: Bookmark dialog 

 

4. Scroll through the list of bookmarks, by Bookmark name, 

5. Press Cancel or Close to exit the dialog. 

 
The items listed within the Bookmark dialog are all bookmark fields in use for the opened document.  
Use the features described in the table below to become familiar with them. 
 

Bookmark Dialog  
Options Description 

Add Allows for the user to add a bookmark field to the place they are referencing 
within the document.  Any point within the document can be bookmarked and 
can contain multiple bookmark references, as well. 
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Delete Pressing this button will delete whatever bookmark is being referenced within the 
Bookmark name field.  NOTE: Deleting the bookmark reference will not remove 
the actual text that it represents. 

Go To This will take the user to the location of the bookmark within the document. 

Sort by Sorts the bookmark table by either its Name or its Location within the document.  
To see the first named bookmark within the document a user would select 
Location. 

Hidden bookmarks When this option is checked it will display all bookmarks, even those used 
internally by Microsoft Word.   

 
The Bookmark dialog will be referenced in the following section that covers working with the bookmark 
fields. 
 

Managing Bookmark Fields 
 
A user can either edit an existing bookmark document, or they can create one from scratch.  More than 
likely, a user will take an existing bookmark file, modify it, and save it as an entirely different document.  
Since this is common, illustrating both processes concurrently will be relevant to one wishing to do 
either. 
 

Adding, Editing, and Deleting Bookmark Fields 
 
This section describes how a user can add, edit and delete bookmark fields, followed by more 
information on these fields.   
 

Adding, Editing, or Deleting a Bookmark Fields 

1. Locate the source file directory using Windows Explorer (Start > Accessories > Windows 
Explorer).  Note: Refer to the Accessing Bookmark Files section for the first two steps, if 
necessary, 

2. Select the file to edit, 

 

3. Remove the read-only attribute from the file  

a. Select the file with a right-mouse click and the Confirmation Properties dialog box will 
appear, 
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b. Make sure there is not a check in the box next to the Read-only option within the 
Attributes section, 

 

c. Click on OK to keep the change and to close the Confirmation Properties dialog. 

4. Open the file with Microsoft Word, 

5. Make changes to the document, as follows  

If adding a bookmark field  

a) Select the location or text field within the document, 

b) Access the Bookmark dialog (Insert > Bookmark), 

c) Type in the Bookmark name, 

d) Press the Add button to keep the change and to close the dialog. 

-OR- 

Copy (Ctrl + C) the bookmark from the list of available ones within the Available Bookmarks 
document (available through support.moverssuite.com or at the top of the Bookmarks 
topic) and Paste (Ctrl + V) it into the document at the desired location. 

If editing a bookmark  

a) Click on the text field or location within the document that contains the bookmark field, 

b) Open the Bookmark dialog (Insert > Bookmark), 

c) Edit the entry by changing the Bookmark name value, 

d) Press the Add button to keep the changes and to exit the Bookmark dialog. 

If deleting a bookmark  

a) Click on the text field or location within the document that contains the bookmark field, 

b) Open the Bookmark dialog (Insert > Bookmark), 

c) Press the Delete button to keep the changes and to exit the Bookmark dialog. 

NOTE   Changing or deleting a bookmark field can also be accomplished through the Bookmark 
dialog.  Use the dialog to locate the item to change, or to delete, by Bookmark name instead of 
having to locate the text field first. 

6. Save the file  

a. Press the Microsoft Office button for Microsoft Word 2007 documents or select File > 
Save As from the Microsoft Word 2003 toolbar, 

 

http://support.moverssuite.com/
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b. Press the Save As option, 

c. If the application server is Microsoft Word 2003, then choose the Word 1997-2003 
Document option  

 

If the application server is Microsoft Word 2007, then choose the Word Document 
option  

 

d. Select the correct folder when the Save As dialog box appears, 

e. Enter the File name, 

 

f. Press Save to keep the file to the named folder and to exit the dialog. 

7. Exit Microsoft Word, 

8. Set the file property to be read-only by repeating the steps above and making sure that the 
read-only attribute box is checked.  Setting the read-only attribute will protect the contents of 
the bookmark document.  When the document is rendered through MoversSuite, the user will 
be forced to save the document to a different file name and/or location, if they wish to make 
and save changes, 

9. Update the Report setup using the administrative tools, as illustrated in the Accessing Bookmark 
Files section, if needed, 

10. Verify that the document works correctly by Viewing Bookmark Documents. 

 
When the document is generated through MoversSuite, the user has a variety of options available for 
saving and disseminating the file.  In fact, all Microsoft Word options are available to the user, including 
saving, emailing, and printing. 
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Troubleshooting Bookmarks 
 
This section explains the details of some common errors and problems that a user may encounter. 
 

Bookmark Field Replacement 
 
When the program renders the bookmark field, one of the following states will occur as indicated in the 
table below. 
 

Field Replacement Outcome Description/Resolution 

Replaced with Correct Data The bookmark field was valid and referenced correctly by the 
application. 

Replaced with Incorrect Data An incorrect bookmark field was referenced. 

Replaced with Blanks This indicates that no data was retrieved for the record.   

Verify that the user is accessing a record, as evident by the presences of 
an Order Number value within the heading bar.   

If a valid record is being referenced, then verify that the correct 
bookmark field is being referenced. 

Nothing Happens If the text statement that represents a bookmark remains, then the 
bookmark reference was either removed, invalid, or is a duplicate of 
another. 

 
 

File Opening 
 
If the menu contains a report name that cannot be found, then an “Error opening Microsoft Word 
document…” error message will appear.  The error will also indicate the name of the file it was 
attempting to open (Report Path plus the Report Name). 
 

 
Figure 13: File open error 

 
To correct the problem, the user may need to do one of the following  

 Check for typos in the document name 

 Verify that the file exists in the desired location 
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 Verify that the file is accessible to the application 

 

Report Missing from Menu 
 
If the report name is missing from a menu, then check the following  

 Is the document setup correctly within the Reports setup? 

 Is the Report associated to a Report Profile record? 

 Is the user accessing the correct Report Profile record? 
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Additional Notes on Bookmarks 
 
Keep the following in mind when updating MoversSuite bookmark fields: 

 When adding or editing a bookmark field, make sure that it matches exactly to those listed in the 
Available Bookmarks document (available through support.moverssuite.com or near the top of the 
Bookmarks topic).   When possible use the attached template to copy (CTRL + C) and paste (CTRL + 
V) desired fields from it into one’s documents.  Doing so not only copies the text, but copies the 
bookmark reference as well. 

 Verify that the bookmark is not in use before you add one.  If a duplicate bookmark is entered, then 
it will move the bookmark reference from the previous location to the new location within the 
document.  Microsoft Word allows a bookmark field to be used only once. 

 Deleting the text reference of a bookmark field deletes the bookmark, as well.  To delete the 
bookmark only, one must use the Bookmark dialog (Insert > Bookmarks). 

 

Example of Adding Bookmarks to a Document 
 
Assume that a user wishes bold text items listed below (Figure 14) to appear within a letter 
automatically generated by MoversSuite: 
 

 
Figure 14: Sample confirmation letter 

 
The data from the sample could be pulled from the Name, Address, Phone tab: 
 

 
Figure 15: Name, Address, Phone tab section illustrating desired data fields 

 
 

http://support.moverssuite.com/
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A user can find the corresponding bookmarks from those provided within the Available Bookmarks 
document and place them in their own Microsoft Word document: 
 

 
Figure 16: Confirmation letter with bookmark fields placed within 

 
 
The Bookmark dialog (Insert > Bookmark) would appear as displayed below:   
 

 

 
Figure 17:  Bookmark dialog for Sample confirmation letter 

 
 
 
 
 
 
 
 
 
 

 


