General Application Functions > Reports

Troubleshooting Reports

 

This section covers the causes and resolutions to some of the more common reporting problems a user may encounter.

 

Issue:

Document is missing from the list of reports

Cause:

The user does not have access to the document, or the document is not defined.

Resolution:

Verify that the document is established within the Reports setup and that user has appropriate access to the document.

Check the following areas:

Mover’s Suite Administration:

-     Common > Reports Setup  (to ensure that the document is defined)

MoversSuite Administration - web:

-     User Setup > Personnel > User Setup (to ensure that the user is in the correct Report Profile)

Reference the Reports and Letters Report to identify which reports and profiles have been defined to be accessible within MoversSuite.

 

 

Issue:

Document cannot be found

Cause:

The application or the Report Viewer may list an error when it cannot find a file.  The error should include the name of the file that it is attempting to open. 

Resolution:

Verify the settings within the Reports setup of the Mover’s Suite Administration.  If the settings are correct and the file is a Reporting Services Report, then verify that the report is correctly loaded within the Report Server.  If the problem persists, contact an Information Technologies (IT) expert.

 

 

Issue:

Document button pushed, but nothing happens

Cause:

Often a report may take longer to generate than is anticipated.  When the document is generated through a button, no Report Viewer message will display and, often, error messages may not appear.

Another cause could be that the System ID for the button is missing or invalid within the Reports setup.

Resolution:

Wait for the report to generate, or check the System ID setting within the Reports setup (refer to the Accessing Documents through Buttons section for a complete listing).

 

 

 

Issue:

No record found

Cause:

The program was unable to locate any records, or an invalid argument was entered as a parameter.  The latter typically involves the user selecting a system-generated document from the lower section of the Reports menu.  Errors similar to “The … parameter is missing a value” or “0 could not be found” will usually be generated from this.

Resolution:

Verify that the argument was entered correctly, and for system-generated reports, setup the document to be rendered through a button (see the Accessing Documents through Buttons section).

 

 

Issue:

Reporting Services Error

Cause:

There can be a number of reasons that can cause a Reporting Services error, including that the Reporting Service is not responding, cannot find requested document, the requested document is of the wrong type, the application is attempting to pass invalid data to the document, etc.

Resolution:

If the error returned is not enough to identify and correct the problem, then verify that the requested document is setup correctly and that the Reporting Services is running correctly, or contact you Information Technology (IT) expert to identify the source of the problem.

 

 

Issue:

Branch or van line image not appearing on customer statements, invoices, or quotes

Cause:

Image not loaded into the report server or is placed in the wrong folder in Report Manager.  Another cause may be that the document has not been designed to render images.

Resolution:

Verify that all the steps have been followed as documented in the Adding Branch and Van Line Images to Documents section.